What are the system requirements?

Below are the minimum system requirements to run our Auto-Provision modules:

WHMCS Server (Provisioning Server)

  •  - PHP 5.3.7

  •  - PHP cURL Library

  •  - PHP PDO Library

  •  - PHP PharData Class

  •  - WHMCS 5.2

  •  - MySQL 5.1.0

  •  - Ioncube Loader 4.6.1

  •  - PHP functions to enable: ftp_connect(), ftp_put(), curl_exec()

  •  - php.ini must have the extension mysqli set to enabled

 

Hosting Server

  •  - PHP 5.3.7

  •  - PHP cURL Library

  •  - PHP PDO Library

  •  - cPANEL 11.32 or DirectAdmin 1.44

  •  - MySQL 5.1.0

  •  - Root or Reseller access to WHM/cPanel or Admin access to DirectAdmin
    • Note: Reseller level access for DirectAdmin may work if the hosting provider allows API connectivity.

  •  - PHP functions to enable: ftp_connect(), ftp_put(), curl_exec()

  •  - php.ini must have the extension mysqli set to enabled

 

Open Port Requirements

  •  - 21 (FTP - Alternate ports may also be specified in newer versions of the modules)

  •  - 2082 (cPanel Control Panel Unsecure)

  •  - 2083 (cPanel Control Panel SSL)

  •  - 2086  (WHM Control Panel Unsecure)

  •  - 2087  (WHM Control Panel SSL)

  •  - 2222 (DirectAdmin Control Panel - All User Levels)
    • Note: This port can be used for both unsecure and SSL connections, if enabled.

  •  - 3306 (MySQL Database Connectivity)
  • 2 Users Found This Useful
Was this answer helpful?

Related Articles

My hosting provider host does not allow remote MySQL database connections; can I still use Auto-Provision modules?

Unfortunately, all auto-provision modules are most beneficial with their ability to automatically...

My application installation failed, what should I do?

If you are encountering difficulties with the provisioning process, please refer to our...

What are the optimal memory limits for Apache, PHP and MySQL?

For optimal performance of our Auto-Provision modules, please use the following recommendations...